Adapting EVE Online Memory Reading for Chat Window

From reading recent posts here on the forum, it seems to me that CCP has deployed an update to the EVE online client which changed how popular properties of the game’s interface can be found in memory.
Reading the posts at New local chat not read, it seems that this affects at least properties which were found under WindowChatChannel in the memory measurement with earlier versions of the EVE online client.

I do not know if anybody is working on adapting the memory reading code for this specific issue.
I think I can help with this, based on the process we employed before to add new features to memory reading.
To see how this worked in the past, take a look at the thread at Did they catch me? EWarElement in ShipUI

When someone with EVE online installed can provide me with a sample of the EVE online client process which demonstrates a problem, I can look into this.
To collect a process sample, you can follow the guide at How to Collect Samples for 32-bit Memory Reading Development

In case there are multiple people interested in reading something in the chat window and want to provide samples, we should coordinate to try to find a sample which contains everything that should be added.
Having everything covered in a single sample has the benefit that the work can be completed earlier.


Sent one measurement via PM. Thanks.

1 Like

So far, I have one sample from @TheChosenOne with SHA1 of D55E6B278DF275851A879E18AC6D96EC04698E31

If anybody is not confident that one covers their needs, feel free to bring another sample.

In case no other samples become available, I will soon look at D55E6B278DF275851A879E18AC6D96EC04698E31.

I adapted the memory reading to sample D55E6B278DF275851A879E18AC6D96EC04698E31.
You can find the change at:

After this change, I did not notice any discrepancy between the screenshot and the memory measurement.

Let me know in case you see a reason to not merge this into the main branch.

1 Like

How can i update this for myself to test?
nvm i got this.
im using modified ABot and not immediately got how to update dlls for my project.
Works fine for me now. Local chat displayed in measurement as it was before.
But now i got an error in Sanderling.Abot.UI in main.xaml.cs

public void ConfigFromModelToView(ExeConfig config) =>

InterfaceToEve does not contain definition for “LicenseView”…
is it some neccessary thing?

Can someone upload the modified files after the fix?

You can already download it by yourself.
Choose branch at Sanderling
And thats all. Its updated version.

1 Like

Downloaded the adapt-memory-reading branch along with the master branch.
Compiles without errors but gets a Stack-Overflow exception
inside a debug file Common.cs at or around
public static Assembly ReadFromEmbeddedResources(Dictionary<string, string> assemblyNames, Dictionary<string, string> symbolNames, AssemblyName requestedAssemblyName)

    var name = requestedAssemblyName.Name.ToLowerInvariant();

where requestedAssemblyName.Name is System.Reflection.AssemblyName

Has anyone else solved this or am I the only one getting this error.
Thank you.

I looked into the source code but did not find the code you posted.
At which file can I find this code in commit 905d803988615140a995837fde81c921ddb023a7?

I downloaded that branch but I can’t located the exe file… where is it under?

Or do I just put the exe file from before in this folder and run it?

How would I use this alongside the A-Bot? Can I just copy the two edited files from this new branch into the code from the a-bot repo?

Thats from SanderlingABot files. Its not presented in Sanderling project.
Sanderling.ABot.UI → Main.xaml.cs
I just quoted it and nothing changed. I think i can just left it unchanged.


You need to update dlls that used in ABot such Sanderling.dll, Sanderling.UI.dll and etc. You need to place it in lib folder in ABot and Build the project.

1 Like

Is anyone else experiencing the error that @Maniac posted?

In ./src\Sanderling\Sanderling.Exe, there is no bin… is it because it’s hidden? or perhaps I downloaded the wrong folder?

Im not.

Meh, you need to build the project to make it appear. ctrl+shift+B hotkey.

1 Like

2 posts were split to a new topic: Questions about A-Bot from TheChosenOne

To help people reading here, I moved some posts which are off-topic to another thread. You can now find those at Questions about A-Bot from TheChosenOne

The process to update A-Bot is being described at Questions about A-Bot from TheChosenOne - #7 by Viir

5 posts were split to a new topic: Unihershey building A-Bot

I released a new version of the Sanderling App which includes the udpates for the chat window: Sanderling App Release March 2018

Thank you for this update. It fixed the issue perfectly.

how to use ite with bot-a?