Sanderling release v17.02.17

Sanderling release v17.02.17 was published, containing a fix for the memory reading contributed by @dreambottle.

Changes since release v17.01.18:


Hi, Im currently using the newest version of Sanderling and I warp out and mine and such just for my cargo to get full and not warp back to station to sell. Any fix?

And yes, I have a bookmark for the station.

yes that is not a bug it’s just because you use the cargo hold ans not ore hold
i can make an update in my bot for set option for use cargo hold or ore hold but i think it’s not worst because ore hold is more big than cargo hold

1 Like

Yes, I suggest to use a Ship with an Ore Hold.

Well, I what I mean’t is I use a covetor and my ore hold gets full.

What is in the log when the ore hold is full?

It is like it doesnt even realized it, it doesnt post anything in logs or anything. there is the logs from last use.

I see. First, load the included mining script and start it. This script takes care of undocking warping and so on.

I’m actually having the exact same issue when flying in a Procurer. The code isn’t recognizing the ore hold % and does not warp back to station when at the specified capacity. The code worked perfectly when i was flying the same setup with a Retriever but not in a Procurer.
When docked, it reads the core hold, unloads and undocks perfectly, just doesn’t read the % capacity in hold while mining.

Whats does it write to the log at that stage?

“TimeDateTimeIntraDayCal”: “13.11.49”,
“TimeDateTimeIntraSecMilliString”: “254”,
“CaptionString”: “ore hold fill: %, mining range: 15000, mining modules (inactive): 2(0), shield.hp: 100%, retreat: , JLA: , overview.rats: 0, overview.roids: 4, offload count: 2, nextAct: InBeltMineStep”,
“LineIndex”: 67,
“CharacterIndexInLine”: 1,
“LineIndexInAvalonEdit”: 68,
“CharacterIndexInLineInAvalonEdit”: 2
you can see where it leaves “ore hold fill: %” instead of writing “ore hold fill: 45%” for example.
Like i said, everything works great in a venture and retriever but just doesn’t pick up the hold in a procurer for some reason. i haven’t tried out a covetor yet, though.

1 Like

I see, from the log entry the value here is null and not some number.
In case you use the included mining script, this value is computed as there: Sanderling/Mine.ore.cs at 5dc223deb738f9b835d2d09d78196bd0702dbaae · Arcitectus/Sanderling · GitHub

What does the API Explorer show you for OreHoldCapacityMilli?.Used and OreHoldCapacityMilli?.Max?

Maybe, the important difference will be visible from a screenshot. Therefore I suggest you take a screenshot for both setups, one for working and one for not working and show them here. The most important part here is the capacity gauge in the inventory window which is where the capacity values are parsed.

My application is having a startup error …

“TimeDateTimeIntraDayCal”: “07.07.53”,
“TimeDateTimeIntraSecMilliString”: “640”,
“CaptionString”: “System.Exception: compilation error: (67,1): error CS1529: A using clause must precede all other elements defined in the namespace except extern alias declarations\r\n at BotSharp.ScriptRun.ScriptRun.<>c__DisplayClass61_0.b__0()”,
“LineIndex”: 66,
“CharacterIndexInLine”: 33,
“LineIndexInAvalonEdit”: 67,
“CharacterIndexInLineInAvalonEdit”: 34


In Current State tab, this shows this:

Next statement to execute
Location: Line 66

using BotSharp.ToScript.Extension;

You can fix this error by moving the using directive from line 67 to the top of the script code.