Problem with eve online mining bot

Hi, i have a problem with the eve online miner bot.
It mines just fine, really a good work, it is impressive.
The only problem is that it doesn’t dock when the ore hold is full.
The bot says that it doesn’t know where to dock since he didn’t dock in this session.
Checking the code i noticed that the default station is set to null, is there any way to get passed that? I can’t change the code myself and i can’t download the github rep, so what can i do?

I solved it by downloading all the bot files and executing it in local enviroment, changing the line after the control on the cargo. I replaced the control on the variable with the command given when you have to escape with less than 50% of shield hp, if anyone else has the same problem.

Hello Lomeglio!

No need to download or edit files. In this case, there are multiple ways set the station.

The easiest way is to dock at a station. The bot remembers the station in which it was last docked, and docks again at the same station when the ore hold is full. For example, you can also start the bot while docked in a station. When it undocks, you can be sure it has replaced the default you mentioned.

You can skip that step by setting the station name using the app-settings in the configuration interface:
Enter this text into the app-settings textbox in the app configuration interface at https://catalog.botengine.org/08C2F5B083533BAAA290083127B29E315BC6BF17E6FC10EC0278BB8EC6151A51/configure-run-app/eyJvbmxpbmVTZXNzaW9uIjpmYWxzZSwiYXBwU2V0dGluZ3MiOiJsYXN0LWRvY2tlZC1zdGF0aW9uLW5hbWUtZnJvbS1pbmZvLXBhbmVsPVwiZW50ZXIgeW91ciBzdGF0aW9uIG5hbWUgaGVyZVwiIiwicGF1c2VBcHBLZXlzIjoiIiwic2Vzc2lvbkxlbmd0aExpbWl0IjoiIn0=

last-docked-station-name-from-info-panel="enter your station name here"

image

You can also set that threshold using the configuration interface:

last-docked-station-name-from-info-panel="enter your station name here", run-away-shield-hitpoints-threshold-percent=50

okay, and is there a way to make it dock at a structure instead of a station?

I solved it by doing few tries and twiking the code a little bit.
Now i can mine and compress my ore without having to transport it for hours like yesterday

1 Like

Any chance you can share your code ?

I’m also very interested in the chance of docking at a structure and then compress the ore guys,any one can help me?

Let’s start with docking at a structure: Can you open the context menu on the surroundings button in the system info panel? Does this menu have an entry for structures? You link screenshots if that is easier for you.

Thanks for your time
Yes inside the context menu there are both stations and one structure where a player can dock

1 Like

I see, in that case, the automatic fallback to structures is not enough. The fastest way to support this scenario seems to add a setting.
I implemented this setting here:

You can use the unload-structure-name setting to pick the structure name:

https://catalog.botengine.org/41c221ca9deca0ed80ef5e69d39d6436b7e69e9eb942e60b9152d36ac64248a3/configure-run-app/eyJvbmxpbmVTZXNzaW9uIjpmYWxzZSwiYXBwU2V0dGluZ3MiOiJ1bmxvYWQtc3RydWN0dXJlLW5hbWU9eW91ciBzdHJ1Y3R1cmUiLCJwYXVzZUFwcEtleXMiOiIiLCJzZXNzaW9uTGVuZ3RoTGltaXQiOiIifQ==

1 Like

This is a perfect solution sir!
Just to well understand,configuring a specific station or structure name like in the screen above

We should write just the first name inside the red selection,or the whole name till the end?

In the app-settings, use the structure name as it appears in the info panel when you are docked.
Should appear somewhere here: image

I recommend right clicking on the structure name there to see if it offers you an option to copy to the clipboard.
(In some cases a structure name can appear the same way in the context menu)

Probably it should support both variants of the structure name in settings, that could be added later.

1 Like

Structure docking it’s a super addiciotn.
If you don’t mind here’s the step by step screen to study the process function,i hope it can help

We start where the bot detect that our ore hold si full,docking to a structure (where we can process)

Now we are inside the “item hangar”

Ps in the case this kind of addiction could be merged with the structure setting to have a whole new kind of setup inside the mining bot?

Last QOL would be the chance to set if the bot have to try to compress or not,for example if we are docking in a station where we can’t process,we would disable the process func to not get stucked

1 Like

Thank you for showing how you compress ore. This will be very helpful for coding it into a bot.

At the moment, I am waiting for feedback on app 41c221ca9deca0ed80ef5e69d39d6436b7e69e9eb942e60b9152d36ac64248a3

Did the setting work out for you? Did you get to test this app live?

ready to test
Can i just pls ask how to set up the stricture name using the bat downloadable here 41c221ca9deca0ed80ef5e69d39d6436b7e69e9eb942e60b9152d36ac64248a3 ](FrontendWeb.Main)

tried to download the bot code but ofc running it offline last just 15 minute (and yes i have credits,just purchased thr 300k bundle)

To configure the structure name, first step is to get the structure name:

  • Dock to structure.
  • Copy from the structure name representation in the info panel, using the context menu and the menu entry containing the text “copy”.
  • From the copied text, in case that contains XML, extract the part that is visible, (between the > < arrow characters).

Then you go to this configuration UI: https://catalog.botengine.org/41c221ca9deca0ed80ef5e69d39d6436b7e69e9eb942e60b9152d36ac64248a3/configure-run-app/eyJvbmxpbmVTZXNzaW9uIjpmYWxzZSwiYXBwU2V0dGluZ3MiOiJ1bmxvYWQtc3RydWN0dXJlLW5hbWU9eW91ciBzdHJ1Y3R1cmUiLCJwYXVzZUFwcEtleXMiOiIiLCJzZXNzaW9uTGVuZ3RoTGltaXQiOiIifQ==

Replace the text your structure with the text that you copied from the game client:

You can run the app by running the downloaded script file from the Windows explorer.

if i put unload-structure-name=(the current structure ame i want to use)
i get this

instead if i run without putting any app senting it start normally
any idea?

Can be relevant that the menu in game say Strictures and not structure? i saw into your bot edited file that is used Structure

Tried with the struscure app setting,and when comes the time to dock ,the bot enter a loop where it open and close just the station menu

EDIT 2 done more test and the station name setting works,so i guess maybe there is a problem into the structure one

Interesting. You might have found a new kind of structure name.
Can you send me your structure name in a private message? Then I can see where this error is coming from.

Or alternatively you can just send a memory reading from a time when you were docked. I can get the station name from the complete reading as well.

1 Like

PM sent,let me know :wink: