Mining BOT wont undock

Hello people! I am new to using bots on EVE and having the following problem.

I have set up UI as instructed and have the green tick on the EVE online client!
I have book marked the astroid belt and also the space station i am docking in. However i have to undock manually, but the bot carries every other instruction out including re-docking and offloading the ore into the hanger?.

I have tried removing the book marks still the same problem and re-checked all the settings but nothing obvious there.

I am running sanderling 2018-07-30

1 Like

This problem is in replacing the game pointer. The guys know about this issue.

1 Like

and is solved. (look on my scripts); you have to do yourself the changes because we do not have access to terpla scrips sources

if (Measurement?.WindowStation?.FirstOrDefault()?.ButtonText?.FirstOrDefault(undock =>undock?.Text?.RegexMatchSuccessIgnoreCase("undock")??false  ) != null)
                        Sanderling.MouseClickLeft(Measurement?.WindowStation?.FirstOrDefault()?.ButtonText?.FirstOrDefault(undock =>undock?.Text?.RegexMatchSuccessIgnoreCase("undock")??false  ));

1 Like

Not gonna lie, I spent like the last 5 hrs trying to place that code into the script, and it somehow fixed the issue a few times, but sometimes making me leave the station faster than i can get the ores out. Then while looking at the log, i realized the code was already in the script. I went through your different posts and I don’t know which script of yours has the fix/guide to fix. Could you link it? Thanks a bunch

on beginer mining script, you comment the line and change with I posted above:

so it should result:

void Undock()
	while(Measurement?.IsDocked ?? true)
if (Measurement?.WindowStation?.FirstOrDefault()?.ButtonText?.FirstOrDefault(undock =>undock?.Text?.RegexMatchSuccessIgnoreCase("undock")??false  ) != null)
                        Sanderling.MouseClickLeft(Measurement?.WindowStation?.FirstOrDefault()?.ButtonText?.FirstOrDefault(undock =>undock?.Text?.RegexMatchSuccessIgnoreCase("undock")??false  ));

		Host.Log("waiting for undocking to complete.");


is like that for any script


Thank you so much, finally fully automated. I’m probably gonna work on getting it to sell the ores on it’s own too at some point but that’s unrelated to this post. Thanks again, you’re great


ok thankyou very much.

I have the bot open, but I don’t see anywhere to add script like that. Where exactly do I go to make these edits? I also have the problem with not undocking.

Your the man, thanks for the fix. I didnt try it yet but im sure it will work :wink:

How did you even get access to the script? I’m not familiar with coding, so I have no idea how to access it. I tried opening up the .exe file with notepad, but it was just nonsense.

After following Kaboonus’ link to the file on Github, you can use the Raw button to navigate directly to the file.
In the chrome web browser, you can use the context menu entry Save link as... to save the file to a location on your device. Then you can use notepad or another text editor to open and edit the file.

I have downloaded the cs script and changed the code like Kaboonus suggested, in Microsoft Visual Studio. What do I do now? How do I actually run the script?

Welcome Markowich! :wave:

If Kaboonus was using the Sanderling App, you can run the script by setting up the App as described in the guide from How to Automate Mining Asteroids in EVE Online and then load the script by using the buttons Automate Something Else and Load Bot From Local File.
Then you can start the bot using the Start Bot Operation button.

Since you have already used Visual Studio, you might find the view under Enter Development Environment To Adapt This Bot familiar.

Hell yeah that worked! Thanks man :slight_smile: