Trouble running multiple bots through VMWare

For the last couple of days I’ve been trying to set up a Virtual Machine using VMware Workstation 12.5.7, taking advantage of it’s ability to deal with 3d graphics.

I’ve been using VMware Workstation in the past, several years ago (don’t remember which version) and I had no problems.

Currently I’m trying to set up an almost empty system with just a launcher for a single game that I plan to play on the Virtual Machine. It worked perfectly fine (same game) several years ago, when I had worse PC specs so I assumed it will work now.

However there is a persistent problem which I can’t figure out. I’ll do my best to describe it:

I start the game and it’s all working just fine. I get ~200 fps (lowest settings, 1024x768 res, audio disabled) and it’s smooth like butter. However after some time (from 5 to 20 minutes usually) the performance suddenly (it’s not gradual, it’s a very steep difference) becomes drastically worse. I still get the same ~200 fps ingame (measured by both Fraps and ingame fps counter) but it’s not silky smooth anymore, the controls aren’t responding immediately, it looks like a slideshow and camera jumps to a new frame every 1-2 seconds. It’s terrible, it feels like I have 5 fps, even the games apparently run at ~200 fps. When I quit the game and start it again, the whole process repeats. At the start it’s smooth but then (after 5-20 mins) it switches to terrible. The ingame activity doesn’t matter, as I might be sitting on the same level, or even on the same screen and it still happens. The only trigger I observed is that 5-20 minute time period. Ofc I tested that game without VMware and there is no issue with it. It’s a fairly popular game, and noone had a similar problem so I strongly believe it’s a problem with the current VMware version or my lack of ability to set it up correctly (even I’ve done that in the past and the game worked just fine).

I recorded the issue, so please view for the comparison (I’m just rotating the camera ingame with my mouse):

  1. How smoothly it works at the begining: good - GIF on Imgur

  2. How bad it gets after the issue starts: bad - GIF on Imgur

So far I tried all of the following settings/configurations:

1-6GB of ram, 1-4 CPU cores, Windows 7 and Windows 10.

60 gb of disk space on a SSD (tried both preallocated 60 gb and flexible, not preallocated max 60 gb).

Accelerate 3d graphics on, with 1gb or 2gb memory.

Ofc I had latest VMware tools installed, I also removed printer/cd-rom/usb and disconnected sound card for best performance.

No matter what, the aforementioned issue still persisted.

Please help.

1 Like

only good advice: stop using that shit. I had exactly same issues, got rid of that shitty software and will never look back.

Then how do you use multiple bots if you don’t use vmware? Do you recommend any other virtual machine softwares or do you just not use multiple bots?

I tried using remote desktop sessions but I read here that someone got banned by CCP using it for macro use… (not botting)

I dont really see how should ccp ban people for using rdp

  1. ccp have no clue if you are on rdp or not, rdp is not virtualised environment and since you are using omega account which CAN run on same computer at same time, there is literally nothing wrong with it

  2. if ccp monitors running processes eg. rdp clients and then concluding something from it? then its privacy breach and in majority of civilised countries its something they can be sued for very very easily and they will be fined heavily. So in my opinion they wont even try,

  3. urban legends

VMware has issues with multicore virtualization, try changing the core count to 1 virtual cpu, 1 virtual core. This will impact performance, but it should be more stable. You don’t want to use RDP because CCP records your computer naming information when it requests information from the client, if you use all the accounts on one machine there is a high probability they will all be banned at once.

If the VM is installed on the same disk as your main use/other active processes, there could be write interference that’s causing the disk to slow down. Data transfer is slowed but the game is still running fine. Try installing the VM on a separate disk.

The EVE client requests your graphics driver and checks to see if it’s VMware, if you have VMware tools installed with graphics acceleration, your driver will be identified as VMware and not your generic driver. VMware clients are considered priority when CCP searches for bots, and you will be banned quickly.

There are some background processes in windows 10 that also effect performance pretty significantly on a single core, I’d stick to windows 7.

To correct this, you will need to edit your driver description in the registry. To hide your VMware presence from CCP:

  1. Open regedit and navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video

  2. Open a subfolder named 0000 in the Video directory, the correct one will have a value called DriverDesc and ProviderName.

  3. Change the value description for DriverDesc and ProviderName to something generic, like NVIDIA Driver. It is recommended that you remove all description references to VMware in this folder.

  4. Always use a VPN or Proxy for each client, otherwise they will be linked by IP

This is the information that CCP requests from the client:
EVE 2724: Values going to the server:
{‘advancedcamera’: 0,
‘audioenabled’: 1,
‘audiohwacc’: 0,
‘autodepth_stencilformat’: 75,
‘backbuffer_format’: 22,
‘bloomtype’: 0,
‘camerashakesenabled’: 1,
‘card_name’: ‘Intel(R) G41 Express Chipset’,
‘code_version’: None,
‘cpu_sse’: None,
‘cpu_sse2’: None,
‘cpu_sse3’: None,
‘dronemodelsenabled’: 1,
‘effectssenabled’: 1,
‘explosioneffectssenabled’: 1,
‘fullscreen_resolution’: ‘1680x1050’,
‘hdrenabled’: False,
‘host_ram’: 2014,
‘loadstationenv’: 0,
‘locale’: ‘en_GB’,
‘lod’: 1,
‘missilesenabled’: 1,
‘multisamplequality’: 0,
‘multisampletype’: 0,
‘network_adapters’: ‘9A6B9D2ACB260F4B70C4DEEAA505AF20\n’,
‘network_computername’: ‘ddee’,
‘network_mac’: ‘1353e37da52f69ab07db756b6b5abd84’,
‘optionalupgrade’: 1,
‘os_build’: 2600,
‘os_hashid’: None,
‘os_majorversion’: 5,
‘os_md5hash’: ‘a047e0af84fda9241c7438ec7a0cf0db’,
‘os_minorversion’: 1,
‘os_patch’: ‘Service Pack 3’,
‘os_platform’: 2,
‘os_productid’: None,
‘os_type’: ‘workstation’,
‘pixel_shader_version’: 3.0,
‘presentation_interval’: 1,
‘processor_architecture’: ‘x86’,
‘processor_bitcount’: 32,
‘processor_count’: 2,
‘processor_identifier’: ‘x86 Family 6 Model 23 Stepping 6, GenuineIntel’,
‘processor_level’: 6,
‘processor_mhz’: 2666,
‘processor_revision’: 5894,
‘shaderquality’: 1,
‘shadowsenabled’: True,
‘sunocclusion’: 1,
‘textureqality’: 1,
‘transgaming’: False,
‘turretsenabled’: 1,
‘vertex_shader_version’: 3.0,
‘video_adapter’: ‘D7B78E667D7211CF58649855A2C2ED45’,
‘video_deviceid’: 11826L,
‘video_vendorid’: 32902L,
‘voiceenabled’: 1,
‘windowed’: True,
‘windowed_resolution’: ‘1024x768’}

The less info you share between your VMs the better. You may change account login and computer name, version of the OS (at least don’t clone machines, install from scratch), customize some settings in first run wizard to not look like a clone.

Let me know if any of that works for you.


Try the 11th version of VMware, 12 have problems.

Here is a funny part, neither of us ever signed or agreed (if i didn’t missed anything) on any updated GDPR rules which they have to have since this year.

What that means they are currently not officially able to gather ANY information which might lead to person identification at any means. Especially they can’t gather and store MAC+IP+email which are considered as high risk data, and so they are covered by tightest rules within GDPR.
And even if they will prepare such a agreement, you have right to opt-out and still use their service.

I’m not saying they are not doing that, I’m just saying that if they will act against anybody in EU they might currently run into pretty big issues if that very person will fight back.
Just a note.

there will be several hundreds of clients linked by IP just because of worldwide NAT usage, so I highly doubt this one.

Good info on eve process btw, thanks!

That’s not how IPs work

Thank you very much.

I have tried doing 1 virtual cpu/1virtual core but when I ran multiple VMs (one eve client on each) the clients lagged very heavily… so I gave up doing that.

I probably need to swap my OS on VM hosts to Win 7 and also just get a separate storage since I have hosts installed on the same storage as the main PC

You could also try using a different version of vmware workstation. Macrolab has a cracked version they recommend. Here is the download link.