Running bot - Elm Error

image Hey, im trying to get bots started only, with almost any bot I am being told my Elm version is out of date, but as you can see here, I am in fact on 0.19.1 already. Any clue whats going on?

That screenshot is too blurry, cannot make out whats in there. Can you post the screenshot on imgur?
Or copy the text from the console window?

The newest version of the console app supports Elm version 0.19.1 (as used by the example bots). The version set in the elm.json file of your bot needs to match that.
This is how it looks in one of the example bots: bots/elm.json at 8a81fc6190e6053abaa2b9941e5c1b8365dba644 · Viir/bots · GitHub

Following that link, I see a new screenshot of the console window with an error message from the app. In that screenshot, I see what the problem is: You are using an older version of the botengine app, from before the switch to Elm 0.19.1. That is why it complains about the bot using Elm 0.19.1

You can download the current version of the app from https://botengine.blob.core.windows.net/blob-library/by-name/2020-01-17.botengine.console.zip

In general, you can find the latest version linked in the guide at https://to.botengine.org/guide/how-to-run-a-bot

When you run the botengine app without any command, it displays the version:

I also have the same error with the latest version.

Capture

I see there is currently an error when starting a bot with the latest version. I get this from the component that should compile the bot code:

-- PROBLEM LOADING PACKAGE LIST ------------------------------------------------

I need the list of published packages to verify your dependencies, so I tried to
fetch:

    https://package.elm-lang.org/all-packages

But it came back as 502 Bad Gateway

This may mean some online endpoint changed in an unexpected way, so if does not
seem like something on your side is causing this (e.g. firewall) please report
this to https://github.com/elm/compiler/issues with your operating system, Elm
version, the command you ran, the terminal output, and any additional
information that can help others reproduce the error!

Related reports:

Looks like people on the elm slack are bugging core devs/maintainers to make the content available again at said URL.

I just tested again and see that it is resolved now.

is there a way to put in a self test for the botengine to tell the user if they have an outdated version of botengine itself when attempting to run?

Also … Can you run bot using botengine from a local source or does it have to be run from an online source ( I was able to launch the warp to 0 bot from online source but not local)?

At the moment, there is no such self test. You would need to spend one minute to check the file name on the guide with the download link. The guide is at https://github.com/Viir/bots/blob/master/guide/how-to-run-a-bot.md
Today, the guide contains this link to download the app: https://botengine.blob.core.windows.net/blob-library/by-name/2020-02-03.botengine-console.zip
The file name includes the version; in this case, it is version 2020-02-03. So you can tell if it is a newer one by looking at the file name.

You can also see the file name changing in the history of the guide document. For example, in the diff view of the last commit Improve navigating the bots · Viir/bots@6c9ee66 · GitHub, we can see the file name changed from 2020-01-24.botengine-console.zip to 2020-02-03.botengine-console.zip

Yes, you can run a bot from a local source, by using the path to the directory on your file system as the source. In case this path contains spaces, you need to enclose it into double quotes like this:

botengine  run-bot  "C:\directory-containing-bot-code"

Getting a new error … believe its related to certificate at codelab.github.com

run-bot failed with exception: System.NotImplementedException: Output file not found. Maybe the output from the Elm make process helps to find the cause:
Exit Code: 1

Standard Error:
'-- PROBLEM DOWNLOADING PACKAGE -------------------------------------------------

I was trying to download the source code for cmditch/elm-bigint 2.0.1, so I
tried to fetch:

https://github.com/cmditch/elm-bigint/zipball/2.0.1/

But my HTTP library is giving me the following error message:

InternalException (HandshakeFailed (Error_Protocol ("certificate rejected: [NameMismatch \"codeload.github.com\"]",True,CertificateUnknown)))

@jyhad do you still get the error containing certificate rejected and codeload.github.com?

Looks good now … unsure of what was causing the error last night …

I don’t remember ever seeing such an error. Cannot rule out the possibility that Github had a bad configuration for certificates for some time. I think it is possible to provoke an error mentioning certificates when interfering with HTTP connections on the client, as some software tools do. (Fiddler is an example). But I don’t know if this could lead to the same error message.