Reading Memory Web Windows 7 error

Im getting error while running the web server on my VM windows 7 x64

First of all, Windows 7 is not supported anymore. There might be other problems preventing it from working with Windows 7.

Now, regarding the current error:

In your screenshot, I found this error message:

certificate has unknown CA

I have observed such error messages on a system with stricter SSL certificate configuration than found on Windows 10: elm-fullstack/2018.deploy-to-azure-web-app.md at c1b9d57ce89f3421dae2e878a1b9327cc63acac3 · elm-fullstack/elm-fullstack · GitHub

Maybe the configuration regarding root certificate on your system is different from the default coming with Windows 10?
Windows does not determine this configuration; it just provides a default. You can adapt it to your needs. On the elm package website, we can see the certificate that needs to be allowed for the elm compilation (that is the part that failed in your screenshot).

When you open https://package.elm-lang.org/all-packages, what does your web browser say about the certificate?

https://package.elm-lang.org/all-packages certificate

Does your system classify the certificate as OK?

1 Like

if i open with the browser it opens normall, no errors.

What OS i should use?
win10?

Yes, Windows 10 works.

1 Like

Yeah, now i manage to compile it and run it but im getting other error.

I run the server first then i start from eve launcher the client with the blue start button for reading from live proccess(with already in web browser this page opened in “searching for eve procces”)

Then i started and i get this.

Im using windows 10x64 and vmware 15 workstation pro

I see you try to use the alternate UI for EVE Online. In the case of the alternate UI, starting the game client first should be no problem.


EDIT:
To clarify the order to start things:

  • You can start the game client after the server.
  • You must start the game client before beginning the reading “From live game client process”. The game client needs to be rendering already before you try to read the memory.

Is this problem specific to the alternate UI?
Does memory reading work when you start the bot from https://catalog.botengine.org/4928a8dcf815dea288e2b5300edd1e817f9490247be982b589c10129dc350b7a ?

Note: When using the bot, start the game client first.

I run a test here, using VMware® Workstation 15 Pro (15.5.6 build-16341506)

The bot linked above has no problem with memory reading:

Then I test the alternate UI. Here is the command to start it:

PS C:\Users\User\Downloads\elm-fullstack-bin-1ab87314ca59b2630493514be443d6007c86941e-win10-x64> ./elm-fullstack.exe  run-server  --deploy-app-from=https://github.com/Arcitectus/Sanderling/tree/c7e227d801f6d3f1cd9dd46ae62060f2942ddf60/implement/alternate-ui/source

Memory reading also worked in the alternate UI:

I recorded a video so you can see if im doing something bad

Im not using the bot at the moment cause i just wanted to learn to read memory first or test it atleast.

(the window at right is the eve start screen , for obvius reasons I hide the name and just let the play button)

here is another sample of reading memory with read-memory-64bit witouth problem, the problem is with the web UI now with reading memory(i think)

fixed, you can close , was a low ram/cpu issue in the VM

Good to know it works now for you :+1:

I am not sure the way shown in the video was bad, maybe that can work out, but I certainly don’t recommend this way.
The order of steps in the video surprised me. I would not try it with this order.
Here is what I do different: Before I click on the “From live game client process” button, I start the game client and wait until the game client renders something.

1 Like