No Green Checkmark

Hello all

So I’ve downloaded A-BOT from the branch “use-current-sanderling” and compiled it. The interface section will not give me a green tick on Last Measurement. I’ve restarted client, bot etc. No joy. Any thoughts?


I can guess. Maybe it matters if the process is started as 32 Bit or 64 Bit process.

I have a machine here with eve online client installed on which I see the green checkmark. The Windows Task manager displays the text (32 bit) on the process.

Also some other information about the environment:


Microsoft Windows [Version 10.0.14393]

And then there is another thing you should measure on your machine:
Do you get the green checkmark in the Sanderling app version 2018-03-24 in the tab titled EVE Online Client?

Using Win7 x64 and everything is ok.

I am running win 10 with the latest build. Eve aswell as the bot engine are running in 32bit. The check mark on the eve online client process in the bot window is green. The checkmark in the last measurement tap is red. I also tryed to run the bot and eve in compatibility mode win 7 still doesnt work :confused:issues

Can you share your VM settings? I was using W10. Just installed and trying W7 now but it’s slow as shit

where i can find the v2018-03-25 version ? i think i missed a link somehow;


where did you get that version (2018-03-25)? I can only find this one: Releases · botengine-de/A-Bot · GitHub


[ Pointless text for minimum post characters ]

Same folder but different branch.

1 Like

OK I’ve tried W7 too and still no joy. The Sanderling app works fine, it’s just this branch doesn’t seem to want to work :frowning: I even tried installing Visual Studio on the W7 machine and compiling it there.

@Anonymous0012 do you get the green checkmark in the Sanderling app version 2018-03-24 in the tab titled EVE Online Client?

Hey Viir,
All i see is the “eve client process” tab. As shown on my picture it turned green.
Its the Sanderling app version 2018-03-24. Its just showing an incurrect date at the top.

ABot != Sanderling. Its ABot on your screenshot but @Viir asked you to try Sanderling and answer is it works or not.

its working with the Sanderling app version 2018-03-24!!

I do not know yet which part of the difference is between the two apps you tested is relevant for your setup.

Maybe your A-Bot process was running into a timeout when attempting to take the memory measurement.

From this idea, a question about your setup follows:
When you are running both Sanderling v2018-03-24 and A-Bot v2018-03-25 and the measurement in A-Bot fails, what measurement durations do you see in the Sanderling App under EVE Online Clientlast measurementSummary?

Mine is the same as Anonymous0012

284 milliseconds is normal, I do not expect effects of a timeout in this case.

I spend some time on investigating why memory measurement does not seem to work in A-Bot 2658cdfa0ecf5936fbb3f17cb91535008ceb573d:

I set up a machine with an EVE online client to test this.

Run the A-Bot and also did not get the green checkmark.
Start A-Bot with Visual Studio 2017 Debugger to take a closer look.

Search for a portion of the source code where the memory measurement is retrieved and found A-Bot/App.Sanderling.Interface.cs at 2658cdfa0ecf5936fbb3f17cb91535008ceb573d · botengine-de/A-Bot · GitHub

After placing a breakpoint on the following statement, I see the measurement has a value of null.

In the output window, I see nothing suspicious.

Next, I look for .NET runtime exceptions.
In Visual Studio 2017 Exception Settings I set the checkmark for all Common Language Runtime Exceptions under Break When Thrown.

VS reports no exceptions while the program is running.

I try to step into the MeasurementTake invocation but VS steps over.

I change debugging settings to disable the option Enable Just My Code.
After this change, Visual Studio reports an exception on the line where MeasurementTake is called:

System.IO.FileNotFoundException: ‘Could not load file or assembly ‘System.ValueTuple, Version=, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51’ or one of its dependencies. The system cannot find the file specified.’

:tada: So it looks like Enable Just My Code interferes with the Break When Thrown in the Exception Settings.

After seeing the exception, it was obvious to me what to try next.
I adapted the A-Bot code and saw the green checkmark on my machine with this version:

How does it look on your system?

Its working for me now ! Big thanks!!!