My credits have disappeared

I had over 300k credits and now I have 0. How does this happen? I have not used the bot for a few weeks.

Seems there was a misunderstanding about how to see the credits balance.
You can now see your credits balance at https://manage.botengine.org/credits
On that page, under Current Balance you will see a text like this:

The current balance of this account is +392840 BotEngine credits

To see this, you need to log in with the same account that you used to redeem the credits voucher. The account you added the credits on is the one starting with auth0|5c
This user id is also displayed on the same page, so you can check if you logged in with the same account.

When you log in with another account, you do not see the same credits.

Is this a frequent problem? I haven’t used mu credits for a while but I should still have well over 300k. Is there an expiration on credits? I don’t remember reading anything like that. It’s been about 6 months.

http://www.awesomescreenshot.com/image/4618663/34f200b11252edd7040c639740a48cc9

http://www.awesomescreenshot.com/image/4618664/3d024138b6f44ef76e00a814a54f4608

Hello Mark,
Sorry for the inconvenience. There is no expiration on credits. Looking at the screenshots, it seems like a bug in the billing system from 2018. It is not used anymore for new products since 2019, but it should still be running and continue to work for you.
I investigate and will update this thread when I know more.

Hello Mark,

To see the credits balance, you need to log in with the same account that you used to redeem the credits voucher. The account you added the credits on is the one starting with auth0|5c
This user id is also displayed on the web page, so you can check if you logged in with this account.

When you log in with that account, you will see this on the web page:

BotEngine Credits

For account with ID auth0|5c11967634e05520bfa92e8e

Current Balance

The current balance of this account is +274232 BotEngine credits

When you log in with another account, you do not see the same credits.

In the screenshot you linked, I see you logged into another account, with an ID starting with google-oauth2|11.
To log in to your account with the credits, enter your Email and Password on this login screen:

If you use the Sign in with Google option here, you end up on a different account and see a different credits balance.

I just signed in and it takes me to an error pg. I had the wrong pw then changed it and can’t get in now. I signed in with my e-mail, not google.

Error Page

In that last linked screenshot, I see no URL. From the looks, it looks like this was some page from auth0. I will have a look if auth0 logged something related. Maybe they have a report on the “service outage” mentioned in the text from the screenshot.

What do you get when clicking on the See details for this error link?

I see auth0 offers details in a log which can be filtered by time:

access_denied : Password login via OIDC-conformant clients with externally-hosted login pages is unsupported. Alternatively, login could have been initiated from the wrong place (e.g., a bookmark).

VIEW LOGTRACKING ID: 7fa7f53e9871e9a9b91b

1 Like

Ok, that helps. I have a new idea.

Can you start on the web page https://manage.botengine.org/login ?
You should see this page there:
image

When you click that first link on that page, you should land on a page that looks like this:
image
(The complete URL will change from time to time, I only know it will start with https://botengine.eu.auth0.com)

Do you get this far?

It’s letting log in. I still don’t know where the right app is to run the bot. Does this look familiar?

2020-03-25-run-app-00736DF1E9-tribal-wars-2-farmbot

Good to see the log in is solved :+1:

The app to run the bot depends on which bot you want to use.

For the Tribal Wars 2 farmbot, you can use the script from https://github.com/Viir/bots/blob/master/guide/tribal-wars-2/farm-manager-tribal-wars-2-farmbot.md

In case you have not yet installed the botengine app version 2020-03-18 or you are not sure, you can follow the steps from https://to.botengine.org/failed-run-did-not-find-botengine-program to install.