Mining Bot isn't working

I have tried the offline version of the BotEngine for Eve Online and it worked fine. I have bought the credits and wanted to turn it into online but it is not working! I run it from the command panel and it seems to run perfectly fine. Finds the online key etc. But then all it shows is … is running. Press Shift + CTRL + ALT keys to pause the app.

Last app event was 0 seconds ago at 21-59–… There are 0 tasks in progress.
Status message from app:

*** seconds ago, I received the following settings.

That’s it… and it is not working… I hope there’s a solution for this problem because although it is not working, the time is wasted in the online session and therefore a decrease of credits…

Thank you in advance

can you show a screen of your app setting? in the page where you download the .bat to run the bot

1 Like

Welcome Anthony,
sorry to read you are having trouble.

That does not look like a mining bot. Looks more like another app. In that text, I see no relation to EVE Online.

In the app settings UI, you can see the app on the same page above the part that is shown in your screenshot.
The app description on that page says:

{- This bot demonstrates how to remember the app settings string.
   It takes any settings string received from the user and stores it in the app state.
   This app also updates the status message to show the last received settings string, so you can check that a method (e.g., via command line) of applying the settings works.

Besides scrolling up, you can also see the app ID on the green download button. On the download button, the second text line starts with “run-app-2e308a”. That part after “run-app-” is the start of the app ID. Using this, we can find the app on the catalog:

So let’s find a mining bot for EVE Online.

I see this one:

The description for this app says:

{- EVE Online mining bot version 2020-06-03
   The bot warps to an asteroid belt, mines there until the ore hold is full, and then docks at a station to unload the ore. It then repeats this cycle until you stop it.
   It remembers the station in which it was last docked, and docks again at the same station.

If you want to run it from the command line, you can use this command:

botengine  run

If you run this one, the engine will display the first part of the app ID in the title of the engine window:

This way, you can always check which app is running, independent of the text inside the window.

Hello Michael,
thank you for the detailed walkthrough. I have copied the command and ran it via command line and it worked. Will it be enough? I mean, I have bought the credits so I want to run the bot while I’m working/Sleeping and I don’t want the free 15 minutes version. What else do I have to do to assure that this bot is running from “my” account and is using my credits. I hope I did not confuse u know. All I want is to run it from an online session

Right, to run it in an online session, I go into the configuration UI and check the checkbox at --online-session:


This is a link directly to the configuration for online sessions:

When you download the script or use the command-line from that link, it runs for 24 hours unless you stop it earlier. (To go beyond 24 hours running time, you would need to use a different configuration.)

When you have started an online session you can see this confirmed in the reactor user interface at
On that page, you will see a new entry for the session under " Most recent online sessions". This entry also shows you the app ID, the first line of the app description (In your case that is “{- EVE Online mining bot version 2020-06-03”), the start time, etc.

nevermind! Found it ! A huge thank you again! :slight_smile: