Mining Bot Help

This is the issue I am currently running into. Does anyone have any advice on how to fix it?

Picture of Command Prompt
Game Screen Shot

In the command prompt readout you posted, I see the memory reading failed. You need to switch your EVE Online client to 32 bit mode, as explained in the guide at bots/how-to-automate-traveling-in-eve-online-using-a-warp-to-0-autopilot.md at f90c6d77ccfdbf1982076e83dc2169012f4aeafd · Viir/bots · GitHub

  • The bot we will use in this guide only works when the EVE Online client is configured to not run in 64-bit mode. Make sure that the setting Run clients with 64 bit is disabled for the EVE Online client. You can check this in the settings dialog shown in the screenshot below:

Settings Dialog in EVE Online

Wow, that worked perfectly. I had disabled it about a month ago, I’m not sure why it re-enabled it.
Thank You for your help.

I have ran into one other problem, when I run the bot now, I am getting this. How do i prevent this from happening? I would ideally like it to run for longer then 15minutes.

Bot session finished: Reached maximum duration for offline session of 15 minutes. To run the bot in a longer session, start an online session.

Bot session finished: Reached maximum duration for offline session of 15 minutes. To run the bot in a longer session, start an online session.
[2019-12-18T09-09-09] Bot session ended.

You can run a longer session by starting an online session: https://to.botengine.org/guide/online-session

online bot session UI

I am attempting to do this. I set up an account with the link provided on that guide, and it keeps telling me to “Log In”. Even after I log in, it will redirect me to the previous log in page. My account was verified via the email the site sent me.

Disregard, I played with the URL a little bit and I believe their standard login is having issues. I tried manage.botengine.org as a URL and it allowed me to login properly. Thank You for all of the help, I really appreciate it. Now I’m going to attempt to run it, in an online session.

I have tried a couple different ways, and I keep getting these errors now. I am sorry to keep asking questions, this is all very new to me.

Edit**-Posted better resolution pictures to see the issue.

Error Picture 1

Error Picture 2

Sorry for the delay, I see sometimes it takes 15 seconds to complete the login and during that time the “Login” link is displayed. I need to improve the UI for these cases, to display that login is in progress.

Did you get to this view as shown in the screenshot below?

image

The key displayed there (after clicking “Show key” is the only one that works for starting an online bot session. If you used another key, you get the error message that we see in the last screenshots:

Did not find an account for the given key to start an online bot session.

One more thing: Online bot sessions cost 2000 credits per hour. You can reuse the same credit voucher codes purchased for the older version (Even if you redeemed them in the older version of the web app).

I waited for the 15 seconds but it still did not work on that link, so I had to use the previously mentioned way.

This is what mine looks like.

Edit by Viir:
Removed screenshot containing private information.

I also don’t see a spot to purchase credits for when my trial membership expires in 21 days.

I looked at the screenshot you posted. I did not see an URL, but according to the looks it is not from https://app.botengine.org

The online bot sessions only work with the key you get on https://app.botengine.org

I am not sure why the login failed for you, need to investigate this. Did you receive an email to confirm your email address?

I will have a look into the database, based on the email address you used here on the forum.

As long as even the login does not work for you, you should not purchase anything. When the login works, a guide on how to purchase credits is displayed at FrontendWeb.Main

I see there are two user accounts for the Email address you used here. One was created using Google auth and the other one without auth via google. Auth0 says email address has been verified for both, so that should not be a problem :confused:

Login will not work if the web browser rejects the HTTP cookies, so that could be the cause. Best idea I have at the moment is to use a pristine web browser (default settings, no extensions) to login at https://app.botengine.org

I tested the login only with Chrome and Firefox. What web browser are you using?

I was using Firefox, and I actually just tried this with Windows Edge, and it allowed me to log in correctly. I just tried it again after getting access to the website for the correct key, and it appeared to work, but now its saying I don’t have enough credits. Thank you for assisting with troubleshooting, I do appreciate it.

Thank you for the feedback, glad to read the login works.
I am not familar with configuration of Firefox. It is possible there is a Firefox configuration that makes the login fail, but so far I did not find one.