Mining bot getting stuck

Hello, I’ve spend last hour trying to figure it out by myself, apparently I can’t so here I am.

At start it looks well. It undocks, opens ore hold, warps to the bookmarked site and while doing so measures the modules, then after it arrives at site it just gets stuck at

23.42.17 70 ore hold fill: 0%, mining range: 0, mining modules (inactive): 0(0), shield.hp: 100%, retreat: , JLA: , overview.rats: 0, overview.roids: 34, offload count: 0, nextAct: InBeltMineStep

infinitely jumping between lines 103

Host.Delay(1111)

and 272

if (DefenseEnter)
{ Host.Log(“enter defense.”);
return DefenseStep;
}

Producing same log every 2 seconds.
Any clues what’s wrong? Thx in advance. Btw using basic script from newest release from git, changing only bookmark site at

string[] SetMiningSiteBookmark = new[] {
“mine”,
};

and station

// Bookmark of location where ore should be unloaded.
string UnloadBookmark = “home”;

as instructed.

EDIT
So I’ve toyed bit more and found out that the problem lies with other miners than Miner I, when using Miner I it works just fine.
EDIT2
Actually it only works on previous (17.05.18) release, and with any miner, not the newest so as far I’m concerned my problem is solved however it’s stil there for any new folk like me.

1 Like

Welcome @kulubulu !
Thank you for sharing your experience.

This output from the log you posted gets us halfway to understanding the issue:

This log entry means the script has recognized 0 mining modules.

What other miner did you test with?
In this case, recognizing mining modules works by text read from the UI. There might be an uncommon mining module with a name which is not yet reflected in the code for module classification.

Hello.
I’ve tried with Particle Compact Bore and EP-S Gaussian Scoped on 17.05.19 and they didn’t work at all, don’t have access to Miner II or Deep Core atm so can’t test it, currently running fine with Scoped on 17.05.18.

There is this other thread Scoped mining laser - IsMiner - #10 by Viir that seems to answer this actual problem.