Memory Reader - Last Measurement

I am having an issue with the Memory reader. In Station “Last Measurement” has a Green Check. When I Undock I lose it and there is a Red X. I have tried downloading a fresh version of Sanderling v 16.11.17, insuring Main Module File Path is filled in, and resetting the License. What am I missing?

It was working until 2/7 11:00 PM MST.

Try restarting your pc this happened to me once and restarting pc fixed it.

I have multiple times. Not sure what is happening.

Sometimes you get problems connecting or loosing conection to sanderlings license server but I am using sanderling right now and is working ok.It could still be a problem with you isp too so try restarting your router .If that dont work I realy dont know.

Its annoying the people that actually know all the answers are not here much making it very hard for amateurs like myself.
I wish this community was bigger.

I have found this forum very helpful. I will contribute as I learn.

Thank you for your help. However, the problem persists. Hopefully someone with an answer will see this soon.

Strange, I do not remember a case like this.

  • Does the time of last measurement change at all while undocked?
  • Do you get new measurements after docking again?

I suggest you take a sample of the eve online client using this tool: How to Collect Samples for 32-bit Memory Reading Development
and send me a link where I can download it. Maybe this will be sufficient to repro the issue here.

No, the only change happens when I Dock.

Yes, everything works while Docked.

Files sent via message.

I downloaded the file you linked (SHA1: E9421A4304CCC6DE17671C8552A48D6569E24875) but the contained screenshot shows the station window, so I guess this is from a time when the char was docked and not the measurement you actually intended to send.

I will look into it. I took that measurement while in space.

I updated the files. Same link.

Thank you.

With the measurement 8A52D07E38F2C47B5514DD492D5CF69065BF4B4B from today, I was able to reproduce the problem here. I will release a new version of memory reading with a fix for this bug.

1 Like

Thank you.

I am newish to coding and having a blast with this. It will be good to get back to it.

1 Like

I published version 17.01.18 of the Sanderling executable at Releases · Arcitectus/Sanderling · GitHub

This uses the fixed version 17-01-18 of the eve online memory reading.

Does it make sense to update for those, who didn’t experience described problem?
Or, in other words, is it specific fix or it improve overall stability of readings?

No, this release was mostly for the problem @DavSan experienced. The only other change was the improvement of visibility of the SelectedRightItemFilteredCount and SelectedRightItemDisplayedCount properties on the inventory windows parse API.