Exception running the bot

when i tried to run a bot i got this wall of text:

run v2020-08-24 failed with exception: System.NotImplementedException: Failed fo
r 1 attempts. Output file not found. Maybe the output from the Elm make process
from the last attempt helps to find the cause:
Exit Code: 1
Standard Output:
Dependencies ready!

Standard Error:
'-- PROBLEM LOADING PACKAGE LIST -----------------------------------------------

I need the list of published packages to verify your dependencies, so I tried to



But my HTTP library is giving me the following error message:

InternalException (HandshakeFailed (Error_Protocol ("certificate has unknown


Are you somewhere with a slow internet connection? Or no internet? Does the link

I am trying to fetch work in your browser? Maybe the site is down? Does your
internet connection have a firewall that blocks certain domains? It is usually
something like that!

at Kalmit.ProcessFromElm019Code.CompileElm(IImmutableDictionary2 elmCodeFile s, IImmutableList1 pathToFileWithElmEntryPoint, String outputFileName, String e
at Kalmit.ProcessFromElm019Code.CompileElmToJavascript(IImmutableDictionary2 elmCodeFiles, IImmutableList1 pathToFileWithElmEntryPoint, String elmMakeComma
at Kalmit.ProcessFromElm019Code.ProcessFromElmCodeFiles(IImmutableDictionary 2 elmCodeFiles, Nullable1 overrideElmAppInterfaceConfig)
at Kalmit.PersistentProcess.PersistentProcessWithHistoryOnFileFromElm019Code.
.ctor(IProcessStoreReader storeReader, IImmutableDictionary2 elmAppFiles, Actio n1 logger, Nullable1 overrideElmAppInterfaceConfig) at BotEngine.Windows.Console.RunAppSession.Run(TreeComponent appCodeTree, Fun c2 getFileFromHashSHA256, String appProcessRecordingDirectory, Action1 logEntr y, Action1 addSessionLogEntry, String appSettings, String sessionCustomName, Ap
pSourceStructure appSource, String keyToStartOnlineSession, IEnumerable1 sessio nLengthLimits, IImmutableList1 pauseAppKeys, IImmutableList1 statusDisplayAddi tionLines, RunSimulation simulation) in D:\a\dev-of-botengine\dev-of-botengine\i mplement\client\windows-console\BotEngine.Windows.Console\RunAppSession.cs:line 55 at BotEngine.Windows.Console.BotEngine.runAppWithOptionsFromCommandLine(Strin g appSourceInputAddress, String appSettings, String pauseAppKeysString, Boolean onlineSession, String keyToStartOnlineSession, String sessionLengthLimitArgument String, RunSimulation simulation, Nullable1 detailedSessionRecording) in D:\a\d
ows.Console\Program.cs:line 690

i tried to disable windows firewall and tried another bot, same result

Yes, that error is not specific to the app.
This error can happen depending on your certificate configuration in Windows. You will not get this error with the default configuration from Windows 10.

I have seen such an error before:

I have observed such error messages on a system with stricter SSL certificate configuration than found on Windows 10: elm-fullstack/2018.deploy-to-azure-web-app.md at c1b9d57ce89f3421dae2e878a1b9327cc63acac3 · elm-fullstack/elm-fullstack · GitHub

Maybe the configuration regarding root certificate on your system is different from the default coming with Windows 10?

When you open https://package.elm-lang.org/all-packages, what does your web browser say about the certificate?

https://package.elm-lang.org/all-packages certificate

Does your system classify the certificate as OK?

What version is displayed when you open the program winver?

i am using win 7


and the page you are refer ing to is not anything like yours


I am not sure it makes sense to invest into Windows 7 support. How did you choose Windows 7? How long does Microsoft supply security fixes for Windows 7?

the laptop that i am using for botting came with vista, so win 7 is progress of a kind :smiley:

Thanks for the input, now i know what to look for :slight_smile: