Eve - WindowInventory.ActiveShipEntry null

Not sure if it’s due to game patch or due to some setting I changed.

WindowInventory.ActiveShipEntry is always null now.

Is this an issue exclusive to me?

Screenshot is too large to upload (limit 40kB)

Not sure about the category for issues//bug reports.

no, the inventory work fine.
but can you say in what context, what script or even what code doesn’t work?

1 Like

In script and I look in Sanderling > Development Tools, it is empty in the tree view

Uploaded screenshot to imgur

Btw, is there some information in this screenshot that is unique to my account, which I should hide?

I use ActiveShipEntry to get Ore Hold on the miner.

As a (hopefully temporary) workaround I do a regex on SelectedRightInventoryPathLabel.Text

  IInventoryCapacityGauge OreHoldCapacityMilli = null;
  if (WindowInventory?.ActiveShipEntry != null && IsExpanded(WindowInventory?.ActiveShipEntry) == true) {
    if(ShipHasOreHold == true) {
      var cargoSpaceType = ShipHasOreHold.Value ? ShipCargoSpaceTypeEnum.OreHold : ShipCargoSpaceTypeEnum.General;
      ITreeViewEntry inventoryActiveShipOreHold = WindowInventory?.ActiveShipEntry?.TreeEntryFromCargoSpaceType(cargoSpaceType);
      OreHoldCapacityMilli = (InventoryActiveShipOreHold?.IsSelected ?? false) ? WindowInventory?.SelectedRightInventoryCapacityMilli : null;
  } else if (WindowInventory?.SelectedRightInventoryPathLabel?.Text.RegexMatchSuccessIgnoreCase("Ore Hold") == true) {
    OreHoldCapacityMilli = WindowInventory?.SelectedRightInventoryCapacityMilli;
  int? OreHoldFillPercent = (int?)((OreHoldCapacityMilli?.Used * 100) / OreHoldCapacityMilli?.Max);
1 Like

did you see your char name there? dont think so :slight_smile:

it seems your window inventory is not opened or is not read.
*restarts computer OR

  • taskmanager kill game and kill Sanderling
    ** later if I remember correctly, there are 2 ways to measure if the ship has ore hold or not, depending of script. try to adapt from other script.
    but mostly you have a flaw on reading your active ship. look if you have the general inventory opened ( and un compact mode) and not the one where it is show only the active ship

Eventually that worked out, a few restarts, waited until undocked to start Sanderling, not sure what worked exactly but works now. Not sure what goes wrong, I’ll check the source code out at some point hm.

Thanks x)

1 Like

is not from the code, actually. is from windows and eve. in time, after hours of play, the memory start to be rearranged (in stockpile). more chars, more soft’s opened ( browser , etc etc) disconect reconect etc increase the chances to have flaws. Also the cache game have his role ( because the game put there some infos, so you dont have them in active memory)
Is what I think, since I’m not a pro programmer, I have no ideea

I noticed it only exists under Parsed measurement, not the raw measurement so must be the parsing fails somewhere (due to game or Sanderling parsing method, I wouldn’t know)

Now to wait for downtime to end ^^

1 Like