Eve Online Mining bot not working

So I got the Eve Online mining bot version 2020-12-07. I started with the 15 minute limit to test it out. Loved it so I bought credits for the 150 hours and started doing online sessions. It worked great for the week.

Then returning to station which I launched out of quit working. Now when I start the script, it always freezes at “Starting the app…” and the log file just stops there with no error messages.

I also tried the 2021-01-06 version as well with the same outcome.

Here is an image of the bot where it freezes: botengine-eve — ImgBB

Thanks for any help.

Going by the screenshot, it looks like the problem is not specific to the app.

I have heard of problems when running with a low amount of free space on the file system. I am wondering if this could be the cause in this case.
The engine tries to write some files at the stage where it displays the “Starting the app…” message seen in your screenshot.

Do you have more than 200 MB of free space in the file system when starting the app?

I see the engine tries to write files in these two directories:

  • %temp%
  • %localappdata%

These are variables that point to concrete directories depending on your Windows configuration.

You can see where these lead by copying the text into the Windows Explorer address bar.

Depending on your system setup, these directories might be on the same or different volumes. For each affected volume, having 200 MB of free space remaining is a good idea.

Thanks for your response. I have over 15 GB of space free, so lack of space isn’t the issue. I’ve never coded in Elm, but the source makes sense. I’ve been slowly digging through the bot init process. I just can’t figure out why it freezes.

Any ideas would be great. I’ll report back. Thank you for your time and great work. I really want to continue to use your bot.

You were correct. It was an available hard drive availability issue. I thought it was NetLimiter which manages all my ingoing and outgoing tcp/udp calls. Nope. Sorry to say, the bot took 17GB of space over around of a month period. I tracked it down by running WinDirStat.

The biggest was %user%/AppData/Local/botengine/run-app-session/2020-12-31T00-39-41-fad359

12.7GB. I think its fair to say. For a bot. Why is it eating up this kind of space??

Here is the stats: bot — ImgBB

You are right about networking limits as a possible cause.
In the screenshot, I see this was the last line in the log in the GUI:

Starting the app…

This step often takes less than five seconds. But the engine also needs to load some components from the internet at this stage. This includes at least one larger file, so the time required here depends on network bandwidth. The engine caches these files on your system so that download should not happen for the second start of an app. However, if that cache is evicted, the engine has to do the download again.

Because it is not a bot. The guide for the recommended mining bot (re)uses a standard botengine setup, which is not optimized for blind botting. In bot development, a lot of effort goes into organizing training data. The engine supports developers and records everything that happens in a session by default. Developers use that data also to build simulations to test their bots faster.
For bot users, this data is important in case they see a problem with the bot. If you conclude that the app worked perfectly in a given session, you can delete the whole session’s recording.
For cases when you know in advance that you will not need the recording, you can disable it using the --detailed-session-recording=off switch in the configuration GUI.

I appreciate the detailed response. Thank you!