EVE mining bot ++ I do not see the mining hold capacity gauge

HI I first time tried mining bot and don’t really know what to do?
panel message is
Session performance: times unloaded: 0, volume unloaded / m³: 0

Current reading: mining hold filled Unknown%. Shield HP at 100%. Found 0 mining modules. I see the drones window: In bay: 2, in space: 0.

  • I see ship UI and overview, undocking complete.
    ++ I do not see the mining hold capacity gauge.
    +++ I am stuck here and need help to continue.

EVE Online framework status:
Reading from game completed

That looks like your character is on a ship without a mining hold.

If you are using bot db8ff73090 or a similar mining bot, you will need to switch to a ship with a mining hold.

thanks for the quick reply,
Yes i use Bot db8ff73090
I fly venture now it uses 2xMiner II,
but i have also machinaw with 2xModulated Strip Miner II and crystals, it give me same error messages.
Dropbox link to Mining Hold views

1 Like

Thank you for the update.
In the screenshots you added I see there is a mining hold visible in the display.

That bot tries to parse the mining hold from memory contents of the game client process. It looks like in your case the shape of memory contents is different from the examples we collected so far. That is why the bot does not recognize it.

When you send me the export of your play-session-2023-11-28T21-27-11 I can use that to adapt the bot to your game client.
If you don’t want to post a link, you can send it to support@botlab.org

i send that play-session-2023-11-28T21-27-11-at-92494-ms-summary to your support email

The summary one does not contain the necessary information about your game client.

The easiest way to export sufficient information is using the ‘Export session recording archive’ button:


oh sorry wrong file, i send now these files to support email


hope it help you found the problem

1 Like

Thank you, that helped. Now I see the problem is with the capacity gauge specifically.

The problem (difference from earlier training data) is even visible in the screenshot you posted from space where your ship is undocked. I highlighted the part where the gauge should appear in this image:


As you can see in your screenshot from in station, there sometimes is a text in there.
How does this part of the UI look when you have an item in the mining hold?

How would you decide that your mining hold is full enough to go for unloading the ore?

Hi thanks again for your reply!! Here is a picture attached again when have ore in mining hold.

In the new picture I see that while there is still no text when in space, at least the progress bar seems to work. So it looks like we can at least derive the relative filling of the mining hold in this case.


Bots can do this by using image-processing, measuring the lengths of the blue part and dark part of that area.

Bot db8ff73090 does not use image processing for this part, since the earlier game clients all showed the textual representation of the fill level that your game client only shows when docked in station.

mmkay… I did try searching the menu if I could find a percentage option for Mining Hold or Garco, but I can’t find one

1 Like

Thank you for the exploration!
I wonder if the display of text in the capacity gauge depends on the way to open the menu.
I remember there are at least three different ways in space:

  • Button in the Ship UI, to the side of the capacitor/hitpoints indications.
  • Context menu entry on the current ship, similar to ‘open cargo’
  • Some entry in the Neocom menu.

Which way do you use for the inventory seen in space?

yeah found it have in inventory mode to combact list on , so i but it off and now it show numbers right, and bot show it also.

1 Like

Thank you for sharing your solution!
So (disabling) ‘Compact Mode’ is what people should look for in such a case.

With your keyword, I found these discussions on the UI flavors: