Elm networking issues

So.
Each time running these Elm applications (tried alternate-ui and botengine) it requires network access.
That’s fine, if it wasn’t for the fact that it drops a named executable to %temp% with random path.

Starting the bot....

run-bot v2020-03-18 failed with exception: System.NotImplementedException: Output file not found. Maybe the output from the Elm make process helps to find the cause:
Exit Code: 1
Standard Output:
Dependencies ready!
'
Standard Error:
'-- PROBLEM LOADING PACKAGE LIST ------------------------------------------------

I need the list of published packages to verify your dependencies, so I tried to
fetch:

    https://package.elm-lang.org/all-packages

But my HTTP library is giving me the following error message:

    InternalException (HostCannotConnect "package.elm-lang.org" [Network.Socket.connect: <socket: 780>: failed (Permission denied (WSAEACCESS))])

Are you somewhere with a slow internet connection? Or no internet? Does the link
I am trying to fetch work in your browser? Maybe the site is down? Does your
internet connection have a firewall that blocks certain domains? It is usually
something like that!

Is there a workaround for this aside from disabling my firewall completely?

For example, you could configure an exception in the firewall for the specific program. The contents of the executable file are always the same.
Another way would be to make an exception for the server package.elm-lang.org.

Need full path to add executables.

Added package.elm-lang.org that helped further, had to add github.com also. Gonna be a problem being if IP’s change tho.

I don’t think Elm will really work with a basic firewall (Windows Firewall) due to these issues.

Thanks for your reply :slight_smile:

Windows firewall also supports configuring exceptions by server address, so at least IP address as criteria should work.

Mid-term, we could also adapt to these limitations in firewall software, by using an implementation that reuses the same file path.