Adapting Combat anom and Mining Bot (EVE)

Hi all!

I’m new to Elm but have experience programming with Java/C++/C#. I’m running into an issue with my Ice Miner that I’m adapting from the Combat Anom and the Miner bot currently on BotCatalog.

I desire the bot to locate an Ice belt, warp to it, and proceed to mine just like the typical miner. I want to use the Combat Anom bot’s abilites to use the probe window to select the Ice belt instead of combat anoms. I received no errors with the current programming but when I run the bot, the box gets stuck.

The bot seems to pause immediately after undocking and displays ----

“I do not see the location info panel. Enable the info panel.”
“I do not see the icon for the location info panel.”
“I am stuck and need help to continue.”

This script is found under the BotFrameworkSeperatingMemory.elm and seems to be basic and fundamental to the bot’s programming yet I did not touch this code.

Any help would be appreciated to steer me on the right track, I may be overcomplicating the function of the bot too… I simply want it to read the ProbeWindow and warp to a “Glaze Belt” instead of opening up the useContextMenuCascadeOnListSurroundingsButton followed by navigating to a random astroid belt.

My code changes/adaptation can be found here:

Welcome Anthony!

I would take a look at your code to learn about your situation, but the link above is broken. GitHub says ‘Page not found’:

In general, if you don’t need the part of the behavior blocking you there, you can remove it from the code.
If you don’t want to use the info panel for your use case, just remove the part of the code that depends on it.


Thanks for the quick reply, I changed the access on GitHub to “public” so it’s now viewable.

As per your response, I just checked the Combat Anomaly bot both (08) and (09). Upon my testing, the bot gets stuck with the error as before:
“I do not see the location info panel. Enable the info panel.”
“I do not see the icon for the location info panel.”
“I am stuck and need help to continue.”

I tried resetting my UI and following the instructions on how to setup the bot, I have no issues with the current version of the mining bot but I believe my issue either lies in my UI config or the Combat Anomaly Code.

img edited for privacy

The link above points to a whole git repository, but not a bot.
The main branch pointed to commit 931d21c9d51703057a88685b52ec3482bca941ca, so here is a link to that: GitHub - k84hero/Iceminer2 at 931d21c9d51703057a88685b52ec3482bca941ca
That tree contains bot 1f1c907d281cd121c5e127f25201801e23d29af6144ac64ff5aa43851bc1e3d9:

In your screenshot, I see you ran another bot: It shows the ID starts with e025c79ef9
So it might have been just a confusion of links to program codes.

You can use this command to run your bot:

botlab  run

Of course, when you have added it to the catalog, you can also use the graphical user interface on the catalog instead.

If you see the issue with another bot, we could also use that bot to inspect your scenario and UI setup.

I found that bot e025c79ef9 was published here: bots/implement/applications/eve-online/eve-online-combat-anomaly-bot at 358bc43a64ec864cc2402e58f6d9a0dc66f6d4f3 · Viir/bots · GitHub

So let’s take a closer look at e025c79ef9. Where do we find the branch indicated in your screenshot?

I found this line as the origin for one of the path element descriptions in your screenshot:

That function depends on memory reading from the game client, so a screenshot is not sufficient to predict the behavior.

What was the memory reading in this step? When we have the memory reading from your game client, we see how that bot ended up in that branch.