Warp-to-0 Autopilot: Bot Clicks not working

Hi. I made a fresh install of Win 10 Home and Eve. I can start Eve and the bot without problem. My problem is, that I see the bot clicking on the first destination over and over again. In my other installation the bot is selecting a menu point after it.

So the bot is showing no effect.

Please help

The problem is the context menu takes too long to appear in this case. The bot only waits a limited amount of time for that menu to appear. If it does not appear in time, the bot clicks the route element marker again.
I made this slower version for you, it waits four seconds: bots/Bot.elm at 10796e6fe41782a8ac57607ba1bfe6fce6517d39 · Viir/bots · GitHub

I’ll try. This could be the problem. I use a very, very old PC as a travel system :wink:

deleted by qmail :wink:


Hi. How do I get this to work? I’m not in these languages :wink:
Normally I use:

BotEngine.exe run-bot “bots/implement/applications/eve-online/eve-online-warp-to-0-autopilot at 8db3758e0bb81a0a1a6016b1a049f5f55a1b6b4a · Viir/bots · GitHub

I replaced it with

BotEngine.exe run-bot “bots/Bot.elm at 10796e6fe41782a8ac57607ba1bfe6fce6517d39 · Viir/bots · GitHub

There is a message that it was mapped to the old location. In spite of it, I tried but no change. I see the menu coming up fast but the mouse pointer is not moving to the next menu item.

That looks good, that should work :+1:

How fast does the menu come up?

What is the content of the bot cmd window?

Hi. Thanks for help. When the bot clicks the first waypoint the menu seems to be completly there within a second.

It runs in cmd Win 10 Home.

Can you make a screenshot of that Window and upload it somewhere? https://imgur.com/ worked well for me.

If the timing is not the problem, the reason could be a difference in the appearance of the menu entry.
Failing to read can happen depending on the appearance in your EVE Online client. It is normal to update the bot in such cases. The more training data we accumulate, the more robust the bot becomes.

Can you make a screenshot of the menu too?

I’ll, give me some time :wink:


Its an absolute fresh install of EVE.

You find a video here.

Is this enough or do you need better screenshots?

1 Like

The video is good. Watching this I see the problem: The appearance of the context menu is not covered by the bot training data so far.
I see that a context menu opens, but the text in there is different. In the bot program, I see it looks for any menu entry that contains the text “dock” or the text “jump”:

In the video, I see the context menu does not contain any such entry. The topmost reads “Durch Sprungtor springen”.

If you change the UI language to English, it should work with the same autopilot bot that you used on your other machine.

I will change the bot or the guide to avoid this problem in the future. I could add a function that detects when the client uses a different language and add a warning message into the bots status display :thinking:

Thanks for help. Normally I play in english but this was a fresh default install.
I bought some credits to support your work :wink:

Stay healthy!

Thank you, I adapted the bot description and the guide to avoid this problem: Adapt to diverse localizations in the game client · Viir/bots@52c4f4f · GitHub