Run-bot failed with exception: System.IO.DrectoryNotFoundException : could not find a part of the path c

i cant start the bot keep getting this error

run-bot failed with exception: System.IO.DrectoryNotFoundException : could not find a part of the path c:\Users\myname\Appdata\Local\botengine.cashe\by-sha256


Sorry for the inconvenience. It looks like this error with the DirectoryNotFoundException was caused by a recently introduced bug.
I fixed this and uploaded this new version of the app at

hey Viir now i ve downloaded the new version u just posted and got an other error

this is the error if the pic isn’t obv

run-bot failed with exception: System.NotImplementedException: Output file not f
ound. Maybe the output from the Elm make process helps to find the cause:
Exit Code: 1
Standard Output:
Dependencies ready!

Standard Error:
'-- PROBLEM LOADING PACKAGE LIST -----------------------------------------------

I need the list of published packages to verify your dependencies, so I tried to


But my HTTP library is giving me the following error message:

InternalException (HandshakeFailed (Error_Protocol ("certificate has unknown


Are you somewhere with a slow internet connection? Or no internet? Does the link

I am trying to fetch work in your browser? Maybe the site is down? Does your
internet connection have a firewall that blocks certain domains? It is usually
something like that!

at Kalmit.ProcessFromElm019Code.CompileElm(IImmutableDictionary2 elmCodeFile s, IImmutableList1 pathToFileWithElmEntryPoint, String outputFileName, String e
at Kalmit.ProcessFromElm019Code.CompileElmToJavascript(IImmutableDictionary2 elmCodeFiles, IImmutableList1 pathToFileWithElmEntryPoint, String elmMakeComma
at Kalmit.ProcessFromElm019Code.ProcessFromElmCodeFiles(IReadOnlyCollection1 elmCodeFiles, Nullable1 overrideElmAppInterfaceConfig)
at Kalmit.PersistentProcess.PersistentProcessWithHistoryOnFileFromElm019Code.
.ctor(IProcessStoreReader storeReader, IReadOnlyCollection1 elmAppFiles, Action 1 logger, Nullable1 overrideElmAppInterfaceConfig) at BotEngine.Windows.Console.Bot.RunBotSession(TreeComponent botCode, Func2
getFileFromHashSHA256, String processStoreDirectory, Action1 logEntry, Action1
logProcessBotEventReport, String botConfiguration, String sessionCustomName, St
ring botSource, String keyToStartOnlineSession, Int32 sessionLengthLimitInMinute
s, IImmutableList`1 pauseBotKeys) in V:\inceptum\BotEngine\dev-of-BotEngine\repo
.cs:line 51
at BotEngine.Windows.Console.BotEngine.<>c__DisplayClass8_2.b__8() in V
dows-console\BotEngine.Windows.Console\Program.cs:line 171
[2020-02-16T14-31-27] Bot session ended.

I have seen such an error before:

I have observed such error messages on a system with stricter SSL certificate configuration than found on Windows 10: elm-fullstack/ at c1b9d57ce89f3421dae2e878a1b9327cc63acac3 · elm-fullstack/elm-fullstack · GitHub

Maybe the configuration regarding root certificate on your system is different from the default coming with Windows 10?

When you open, what does your web browser say about the certificate? certificate

Does your system classify the certificate as OK?

What version is displayed when you open the program winver?

I have another idea what might have caused this problem. In chat, Elm core devs recently announced a change to the site They also warned that there could be interruptions. I have not seen any mention of certificates specifically, but maybe the site was configured to use a different certificate for a short time.

If that was the cause, the problem should not persist for more than one hour.

Do you still get that error?

yes i still get this error i m running windows 7 ultimate downgrade from windows 10 3 days ago before i try to use this script i don’t think the problem caused by the OS version Screenshot_1 Screenshot_2 Screenshot_3

Windows 7? That is not supported anymore. I did not test with Windows 7. Maybe it does the propagation of CA different, no idea.

But besides the certificate problem that you see, I think it is unlikely that the Tribal Wars 2 farmbot works on Windows 7 anyway. As far as I remember, the web browser framework depends on a component that Microsoft added with Windows 8.

thank you mate ill try to upgrade to windows 10 again and test it again