Multi instances Support

Hi guys,

The work you did is amazing, my mining bot works perfectly (when you configure every thing
As expected :slight_smile: ) .

My newbie question is the following: can I run multiple instance of Sanderling and associate each one to a running eve client?
Who the mouse click and selection will be managed?
What I’m trying to do is to use two miners bots on the same PC

1 Like

To use multiple bots on the same windows instance, you can use multiple remote desktop sessions with one session for each bot.

For some editions of Windows, the default configuration only lets you use 0 or 1 such sessions.
To avoid this limitation and enable Remote Desktop Host support and concurrent(multiple) remote desktop sessions, use the following tool:

Please note that this tool might need some maintenance when windows is updated.
In case you run into issues with rdp-wrap, I recommend to check out the issues list at Issues · stascorp/rdpwrap · GitHub
There are many people over there sharing what they did to make RDP Wrapper work in their case.

Have a look at this video guide explaining how to Allow Multiple Remote Desktop Sessions in windows:

Then place one bot and game client in each of the remote desktop sessions:

Since each desktop session has its own mouse and keyboard, no coordination is required between the bots.


Yes. For each instance of Sanderling do the association as follows:

  • In the Sanderling UI navigate to the tab Interfaceeve client process.
  • Select the eve online client process in the list of windows processes under processes found.
  • Use the button set selected as target.
  • You will then see a checkmark in the current target column of the process list, confirming your choice.
  • Verify successful application of the new setting by comparing the process id shown here to the process id shown for the memory measurement.

The following screenshots shows the section of the UI used here:

Thanks for your detailed answer Viir.

Now I need just to test how much simultaneous sessions ( Eve Client + Sanderling ) can i run on my Pc.

I’ve attempted to do this but looks like bot doesn’t work if the remote screen is not focused.

Does this need any extra change in Eve settings or windows?

The idea of focusing a remote screen is new to me.
I don’t understand how that focus could be related, and have some questions about your scenario:

  • Can you focus a remote screen? How would you do that?
  • How would you measure if a remote screen is focused?

By focused i mean, having the RDP opened and visible in screen. Example:

If i minimize or close the remote connection, bot at that desktop does nothing until i login and “look at him” again.

1 Like

hi Tester

May be you should try to use virtual desktop,

in my setup I added 3 virtual desktops and in each one I have a remote desktop connexion.

i’m using “Desktops v 2.0” Link or Link

1 Like

Aha, I remember observing this. You can adjust windows settings to solve this. I found a description of how to enable it to also work when the remote desktop window is minimized on the following site:

Following is the relevant part of the document linked above:

To work around the issue, you can change the Remote Desktop’s registry settings on your local computer (where you launch the Remote Desktop):

On your local computer, close all open Remote Desktop sessions.

  • Launch the Registry editor (regedit.exe).
  • Navigate to one of the following Registry keys, depending on whether you wish to modify the Remote Desktop settings only for the current user or for all users on the computer:
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client
HKEY_LOCAL_MACHINE\Software\Microsoft\Terminal Server Client
  • Create a DWORD value named RemoteDesktop_SuppressWhenMinimized and set it to 2.
  • Close the Registry Editor.

Now when you minimize the Remote Desktop Connection window on your computer, this will not affect the remote computer’s GUI and the GUI will be available to your automated tests.


@BotUser i was already using w10 virtual desktops.
@Viir yes! i suspected something like this was going on. Ty!

I’ve built a mini tutorial containing all steps to make Sanderling work in RDP:

If you have Windows 10 basic editions like Home, RDP is disabled. So if you have Pro editon or higher you can skip this steps:

  1. Download enableRDP.reg from here Enable RDP in Windows 10 Home Edition -
  2. Download PsTools (Process Utilities) from Microsoft website:
  3. Dending on your OS 32/64 bits, extract PsExec.exe or PsExec64.exe
  4. Run CMD as administrator and execute PsExec.exe -s -i regedit.exe
  5. In Registry go to File > Import and select enableRDP.reg

Make Sanderling+Eve work in RDP:

  1. Install rdpwrap → Releases · stascorp/rdpwrap · GitHub
  2. Create a new windows account that will be used in RDP.
  3. Run CMD as administrator and execute net localgroup "Remote Desktop Users" [account_username] /add .
  4. WIN + R → regedit → Goto HKEY_LOCAL_MACHINE\Software\Microsoft\Terminal Server Client
  5. Create a DWORD value named RemoteDesktop_SuppressWhenMinimized and set it to 2.
  6. WIN + R → mstsc.exe → Show advanced options → Point to localhost & set to rdp username to login
  7. Click on connect
  8. Inside that windows account, place a shortcut to EvE online and install/download Sanderling.
  9. Open EvE client and set al visual settings to low (just a bot, he doesn’t need to see everything beautiful.)
  10. Switch the window mode to Windowed, otherwise, everytime you log in remotely, the EvE client will be minimized (stupid windows)
  11. Disable Dynamic Camera Movement. This way game wont change the camera position, allowing you to set it half distance from ship to not hear the noise, just important sounds like incoming attacks.

Now you can run sanderling and let him do it’s job. It will work as long as you are connected and have the screen openend or minimized. Closing the connection will make Windows go GUI less mode on RDP account , so bot will fail to perform any task.


Why use PsExec.exe here?

It didn’t let me save those entries in registry by simply running regedit (i can’t remember the error message).
Source: Allow Non-Administrator Users to Access Windows 7 Home Premium Via Remote Desktop - Super User

rdpwrap didn’t work after creators update on windows 10 home

Just way until they update it, as told in the repo : S


I don’t know if anyone else had problems getting this to work since the creator update, I sure as hell did!
But someone else found the solution thank god, so I will post it here if anyone else wants to do this but cannot get Remote Desktop to cooperate:

The original solution is posted here: Original Solution and here Main Thread

Try this dll file (for win10 home edition) :
Win 32-Bit
Win 64-Bit

Unzip it into the C:\windows\system32 folder (if the file with the same name exists, rename it to rfxvmt.dll.old).
Do these steps with Administrator rights:

  1. Download the right file for your version windows 32/64, from the above links
  2. Put the file in C:\windows\system32 folder (if the file with the same name exists, rename the old file to rfxvmt.dll.old).
  3. Uninstall.bat
  4. Install.bat
  5. Check RDPConf.exe if it says: image
  6. RDPCheck.exe and check that you get to login
  7. If it DOESN’T: run update.bat
  8. Do step 5-6 and pray that it works now.

Good luck!

Edit: Typo :slight_smile:


this thread is for the fucking WIN!

Can confirm that the instructions here do in fact work on Win 10 enterprise

PS C:\WINDOWS\system32> [environment]::OSVersion.Version

Major Minor Build Revision

10 0 15063 0

1 Like

Just a note of warning. Unless you have a way to change the hardware names on each desktop, it will look like you are just using the same computer. So, if you intend to do heavy botting with this, you need to solve that or find a different solution.

that’s an interesting point. hrm. thanks for that.

I tried following all the replies here and also in the forum of the github for the rdpwrap but i keep getting that listener is not working and service state says stopped

Does this still work for people?
I’m running Win7. I have Desktops v2 running.
I have added two users to the the RDP Group and using rdpwrap I have an rdp conenction to my ip address on each desktop.
When I start eve launcher (alpha account ) in one desktop no problems.
If I then start eve launcher on the other desktop/rdp and try and log in to an omega account it says I can’t because I’m already running alpha.
The accounts are not linked on eve launcher they have separate email accounts.

Thanks for any help.